Intermittent Stuttering

Added by Dan Burt 11 days ago

Using TVH with DVB-C tuners. I do not have on-site descrambling, i.e. my own hardware in my setup. But provided the means to connect, via a TCP connection.

I get pretty consistent stuttering on playback. I have been coordinating with my above provider who indicates no issue and does not use TVH. Therefore I need to rule out TVH (bugs, or otherwise).

I need some assistance with this to interpret, etc. I can provide any logs people need. I just want to ensure the correct components are being logged, the logging level (if there is a choice) and where / how to upload, given these log files are likely to be 100's of MB's of text (over the limits of pastebin)?

I just want to watch TV around my house, and need to know if TVH is not as capable / easy as other implementations.


Replies (4)

RE: Intermittent Stuttering - Added by Mark Clarkstone 11 days ago

Dan Burt wrote:

Using TVH with DVB-C tuners. I do not have on-site descrambling, i.e. my own hardware in my setup. But provided the means to connect, via a TCP connection.

I get pretty consistent stuttering on playback. I have been coordinating with my above provider who indicates no issue and does not use TVH. Therefore I need to rule out TVH (bugs, or otherwise).

I need some assistance with this to interpret, etc. I can provide any logs people need. I just want to ensure the correct components are being logged, the logging level (if there is a choice) and where / how to upload, given these log files are likely to be 100's of MB's of text (over the limits of pastebin)?

I just want to watch TV around my house, and need to know if TVH is not as capable / easy as other implementations.

  • What are you using for playback?
  • When the stuttering occurs do you get errors in the [tvheadend] log (open the bottom bar in the webui during playback as an admin user).

RE: Intermittent Stuttering - Added by Dan Burt 9 days ago

I have tried using the TVH CA config as well as oscam for the descrambling.

using TVH CA, i would get "access denied" messages.

when using oscam, the reported error is different in TVH, but dont have the specific error code. as the performance has not improved with this, i am doubtful to return to it, unless others are able to tell me it is the best configuration to use, and i have something incorrect in my setup.

playback is either through a browser, typically when testing, or through kodi boxes in the house that are both using wired ethernet connections.

RE: Intermittent Stuttering - Added by Mark Clarkstone 9 days ago

Dan Burt wrote:

I have tried using the TVH CA config as well as oscam for the descrambling.

using TVH CA, i would get "access denied" messages.

when using oscam, the reported error is different in TVH, but dont have the specific error code. as the performance has not improved with this, i am doubtful to return to it, unless others are able to tell me it is the best configuration to use, and i have something incorrect in my setup.

playback is either through a browser, typically when testing, or through kodi boxes in the house that are both using wired ethernet connections.

Without any logs from Tvheadend it's hard to say what's causing the issue. Do you actually see any errors in the log?

RE: Intermittent Stuttering - Added by Joe User 9 days ago

Dan Burt wrote:

...But provided the means to connect, via a TCP connection.

You need to explain this better - there are many different ways. ( Also you need to describe better (exactly) how you have tvheadend configured to know which modules need to be debugged.)
What version of tvheadend? (Makes difference on debugging options...)

What leads you to believe it is a descrambling issue?

A basic debug with descrambler, csa, capmt, cwc would be a good start.

(1-4/4)