Question About local cable

Added by tony nunya almost 5 years ago

Hey Guys,
Ok here is my dilemma... I have local open cable here now there are 50 channels in
the clear however i only get 14.... Now i have noticed in the info bar a channel that
is broadcasting says

pid 3104     MPEG2VIDEO
PID 103 AC3

Ok eng and mpeg 2 video.. and it plays fine but then i come across this

393MPEG2VIDEO
398AC3
380CAPowerVu (0x0e00) [0x00000000]

which then throws headend into an endless loop no descrambler.. Now on my straight tv I pick up that channel
fine but in tvheadend Oh its a bear... Can someone please explain this to me and Why because obviously
there is an open pid for mpeg2video but then there is that dirty little powervu thing that i do believe is
the culprit... Is there anything i can do about this or not?

Thanks in Advance

Replies (10)

RE: Question About local cable - Added by Hein Rigolo almost 5 years ago

which cable service is this? (country/provider etc etc)

They way you describe it ... it sounds like corrupt dvb-si tables to deliberately prevent what you are doing :-)

Hein

RE: Question About local cable - Added by tony nunya almost 5 years ago

Hey Hein,
Yes i am thinking so too... It is Charter Cable company in the
States... and Like i said they are trying to make sure you can't
even get open cable unless you have a tuner that reachs beyond 900000000 khz
which is rediculous... Now With my windows and mediaportal i had to build
a graph and do it through ntsc... But unfortunatley it won't let me do that
as this is linux now off the qam256 I get about 12 stations that are clear
and they do not have the CaPowerVu thing... All they have is MPEG2VIDEO those
come in no problem but when it hits one of those channels it says of course
no descrambler... Which is Crazy because they are supposed to be free on
the cable system... Is there a way i can go around this?!?!?! Please let me know

Thanks
Tony

RE: Question About local cable - Added by Hein Rigolo almost 5 years ago

to get around this ... you need to hack tvheadend to just ignore the CA that was provided. (but not sure where in the code you need to do that)
But then you really need to know if the signal is really unencrypted.

Hein

RE: Question About local cable - Added by tony nunya almost 5 years ago

Hey Hein,
Yes you know here is the thing... I can build a graph in mediaportal
and get all the channels as atsc But however when i try atsc in tvheadend
i get no signal. When i try 8vob nothing either... But when i go to qam256
there they are... But of course that nasty little powervue crap comes up in
alot of them... If there is an mpeg2video they are in the clear... The problem
is tvheadend see's the powervue crap and tries to descramble it and of course
i would never use such means to get FREE tv.... I am not nafarious.. heh Anyways
Like i said i really need to find out where the heck that piece of the code is
and disable it... I bet once i disable it it will be work...
I am going to have to see if it is in the dvbtransport.c file... I will have to
look for it anyways if you or anyone can shed some light i would appreciate it

Thank you
Tony

RE: Question About local cable - Added by Adam Sutton almost 5 years ago

Try this:

in src/dvb/dvb_tables.c

look for this line (490 ish)
free_ca_mode = (ptr3 >> 4) & 0x1;

this indicates whether or not the the service is encrypted, force the value to 0 and it'll think its unencrypted.

It should automatically update all existing services, but if not try manually editing the config as well:

.tvh/dvbtransports/*/*

and set "scrambled": 0

Adam

RE: Question About local cable - Added by tony nunya almost 5 years ago

Hey Adam,
Thank you bro I appreciate it... When you are talking about the dvbtransports
your talking about modifying the transports each one am i correct? Please forgive
my noobness.. Heh.. I appreciate all that have helped me... Thank you...

Tony

RE: Question About local cable - Added by Adam Sutton almost 5 years ago

I was, but there is another way, I realised after I posted my last comment. If you change the config load function in src/dvb/dvb_transport.c

in function dvb_transport_load() change the remove the lines setting s_scrambled = u32. Should then load config as scrambled = 0

See if that helps. You will still need to make the dvb_tables mod as well or it'll probably just change the setting on the fly.

Adam

RE: Question About local cable - Added by tony nunya almost 5 years ago

Thanks again Adam,
I am going to try this out right now.... I will report back in a little bit after i get
it recompiled Wish me luck I am using Opdenkamps tvheadend... for right now not 3.0

Thank you again my friend

RE: Question About local cable - Added by tony nunya almost 5 years ago

Well Adam,
I did like you said and believe it or not it still says no descrambler Grrrrrrrrrrrrrrrrrrrr......

It is an mpeg2 multicast channel with that nasty little powervue crap also.... I don't know
if i patch the file right or not.. I change the 3 to a 0 and i did the mod for dvbtransport etc...
Stumped here..

Tony

RE: Question About local cable - Added by Anonymous 26 days ago

Thank you for sharing this data. Really increase in value the way you have describe everything in this article. Keep up the decent work.
hotmail login - https://sites.google.com/site/logintohotmail/
hotmail account login - https://sites.google.com/site/hotmailemailhelps/
hotmail email login - https://sites.google.com/site/hotmailemaillogin/
gmail sign up - https://sites.google.com/site/tipstologin/

(1-10/10)