AptRepository » History » Version 59

« Previous - Version 59/81 (diff) - Next » - Current version
Mark Clarkstone, 2017-06-19 09:42


Official APT Repository

The repository is provided by Bintray containing packages built by Doozer.io.

Please note that with the changes to the build system, the list of supported distros has changed. Please check the Supported Distributions / Platforms list below, if your distribution isn't listed there may be an older version available, new build targets will be added as soon as possible.

4.2

This is the current-stable release.

Supported Distributions / Platforms

  • Debian
    • Jessie "jessie" (8.x) - i386 / amd64
  • Ubuntu
    • Xenial "xenial" (16.04.x) - i386 / amd64 / armhf / arm64.
    • Trusty "trusty" (14.04.x) - i386 / amd64 - see note 1.
    • Precise "precise" (12.04.x) - i386 / amd64 - see note 2.

If you're looking for Raspbian "raspbianjessie" packages, please see the Help! below.

Notes:
  1. The armhf and arm64 builds do not have transcoding built in at the moment.
  2. The i386 builds for precise do not have transcoding built in, and seeing as this version of Ubuntu is now EOL it will eventually be removed.

Build types

  • release-4.2 - The latest version marked as release (like 4.2.2).
  • stable-4.2 - The latest official / stable code including changes between releases (like 4.2.2-10~gHASH).

4.0

This is the old-stable release. Please note, there will be no further updates to this version.

Supported Distributions / Platforms

  • Debian
    • Jessie "jessie" (8.x) - i386 / amd64
  • Ubuntu
    • Xenial "xenial" (16.04.x) - i386 / amd64
    • Wily Werewolf "wily" (15.10.x) - i386 / amd64
    • Trusty (14.04.x) "trusty" - i386 / amd64

Build types

There is currently only one build type for 4.0.

  • stable - An old-stable build from the 4.0 release branch.

Development/Unstable

This is the current development "bleeding-edge" release. It contains builds from the development (master) branch on Github. Only use this build if you want bleeding-edge & don't mind breakages!

Supported Distributions / Platforms

  • Debian
    • Jessie "jessie" (8.x) - i386 / amd64
  • Ubuntu
    • Xenial "xenial" (16.04.x) - i386 / amd64 / armhf / arm64 - see note 1 + 2.
    • Trusty "trusty" (14.04.x) - i386 / amd64 - see note 1.
Notes:
  1. Due to issues with building x264, i386 builds have limited transcoding support.
  2. armhf and arm64 builds do not have transcoding built in at the moment.

Build types

There is currently only one build type for unstable.

  • unstable - This will contain a nightly build from the development branch (master)

Usage

First install bintray's GPG key:

sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61 

Select which build type you want and add the repository accordingly:

echo "deb https://dl.bintray.com/tvheadend/deb DISTRO BUILDTYPE" | sudo tee -a /etc/apt/sources.list

Replace DISTRO with the distribution's code name (as quoted in the Supported Distro's / Platforms list).
Replace BUILDTYPE with the desired build type.

Example:

echo "deb https://dl.bintray.com/tvheadend/deb xenial stable-4.2" | sudo tee -a /etc/apt/sources.list

Refresh the available packages and install:

sudo apt-get update
sudo apt-get install tvheadend

Note: if you install more than one suite you will only ever get packages from the one holding the most recent version number, so the order of priority would be:

unstable > stable-4.2 > stable

Help!

Where are the builds for my distro/arch?
At the moment the Doozer build system only has support for a limited number of build targets. New targets will be added as soon as possible. If you're impatient you may build your own packages.

What happened to nightly builds?
They're no longer being provided, packages are now built on-the-fly once a commit to the branch has been pushed.

Is there a stable 4.2 package for Raspbian?
Yes! However it's not official, but pretty close. To use it, you simply follow the usage instructions above but change the apt source URL..
  • From
    deb https://dl.bintray.com/tvheadend/deb
    
  • To
    deb https://dl.bintray.com/mpmc/deb
    

Example:

echo "deb https://dl.bintray.com/mpmc/deb raspbianjessie stable-4.2" | sudo tee -a /etc/apt/sources.list

Please read the following:
  • These builds are done manually and may lag behind, however I'll do my best to keep them updated until the official repo is able to provide the packages.
  • Only stable-4.2 and unstable builds are available. There is no release-4.2 build.
  • There is no transcoding support, mainly because the Pi isn't powerful enough to do software transcoding & hardware transcoding is not yet available.
  • There is no changes to the code whatsoever for these builds.
  • Make sure to enter the distro as "raspbianjessie" and not "jessie".
  • If you experience an issue please contact me on github, or send me a message on IRC - I idle as mpmc in #hts on Freenode.

Is there an Ubuntu PPA?
Unofficial PPAs are provided by Michael Marley that provide packages for Artful, Zesty, Yakkety, and Xenial for the amd64, arm64, armhf, i386 and ppc64el architectures.

First, pick either the Stable or Unstable builds:

  • For the Stable PPA containing daily builds from the latest stable branch:
    sudo apt-add-repository ppa:mamarley/tvheadend-git-stable
  • For the Unstable PPA containing daily builds from master:
    sudo apt-add-repository ppa:mamarley/tvheadend-git

Then, for both:

  • Update your packages:
    sudo apt update
  • Install:
    sudo apt install tvheadend

If you experience issues with this PPA please contact Michael on IRC (mamarley in #hts on Freenode) or Launchpad.